aboutsummaryrefslogtreecommitdiff
path: root/targets/corstone-300/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'targets/corstone-300/CMakeLists.txt')
-rw-r--r--targets/corstone-300/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/targets/corstone-300/CMakeLists.txt b/targets/corstone-300/CMakeLists.txt
index 12902d3..6558e0d 100644
--- a/targets/corstone-300/CMakeLists.txt
+++ b/targets/corstone-300/CMakeLists.txt
@@ -103,7 +103,10 @@ foreach(register ${registers})
foreach(index RANGE 0 1)
set(name ETHOSU_TA_${register}_${index})
set(${name} -1 CACHE STRING "${name}")
- target_compile_definitions(ethosu_target_common INTERFACE ${name}=${${name}})
+
+ if (${name} GREATER_EQUAL 0)
+ target_compile_definitions(ethosu_target_common INTERFACE ${name}=${${name}})
+ endif()
endforeach()
endforeach()