aboutsummaryrefslogtreecommitdiff
path: root/applications/threadx_demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/threadx_demo/CMakeLists.txt')
-rw-r--r--applications/threadx_demo/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/applications/threadx_demo/CMakeLists.txt b/applications/threadx_demo/CMakeLists.txt
index ef20b57..41fabdd 100644
--- a/applications/threadx_demo/CMakeLists.txt
+++ b/applications/threadx_demo/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2021-2022 Arm Limited.
+# SPDX-FileCopyrightText: Copyright 2021-2022, 2024 Arm Limited and/or its affiliates <open-source-office@arm.com>
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -24,10 +24,15 @@ endif()
ethosu_add_executable_test(threadx_demo PRIVATE
SOURCES main.cpp
- SOURCES tx_initialize_low_level.c
LIBRARIES inference_process threadx)
target_include_directories(threadx_demo PRIVATE models/mobilenet_v2)
+# Make ThreadX's HardFault_Handler a weak symbol to use the platform target's handler instead
+add_custom_command(TARGET threadx_demo PRE_LINK
+ COMMAND ${CMAKE_OBJCOPY} -W HardFault_Handler $<TARGET_FILE:threadx>
+ DEPENDS threadx
+)
+
# Use the fast memory to support both 11.12.57 and 11.13.x release
# of the FVP
# The size is defined to force the .bss.tensor_arena to be placed in DDR