aboutsummaryrefslogtreecommitdiff
path: root/applications/threadx_demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/threadx_demo/CMakeLists.txt')
-rw-r--r--applications/threadx_demo/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/applications/threadx_demo/CMakeLists.txt b/applications/threadx_demo/CMakeLists.txt
new file mode 100644
index 0000000..34051f8
--- /dev/null
+++ b/applications/threadx_demo/CMakeLists.txt
@@ -0,0 +1,35 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+# Exclude this app if ThreadX target does not exist
+if (NOT TARGET threadx)
+ message("Skipping ThreadX application")
+ return()
+endif()
+
+ethosu_add_executable_test(threadx_demo PRIVATE
+ SOURCES main.cpp
+ SOURCES tx_initialize_low_level.c
+ LIBRARIES threadx)
+target_include_directories(threadx_demo PRIVATE models/mobilenet_v2)
+
+# Use the fast memory to support both 11.12.57 and 11.13.x release
+# of the FVP
+# The size is defined to force the .bss.tensor_arena to be placed in DDR
+target_compile_definitions(
+ threadx_demo PRIVATE ETHOSU_FAST_MEMORY_SIZE=0xa0000)