aboutsummaryrefslogtreecommitdiff
path: root/applications/driver_unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorKristofer Jonsson <kristofer.jonsson@arm.com>2021-03-10 17:13:52 +0100
committerKristofer Jonsson <kristofer.jonsson@arm.com>2021-03-26 09:27:44 +0100
commitb5f7cfe253dfeadd83caf60fde34b5b66f356782 (patch)
treef2286d8d1b7e1010c61277a80bdf344130c7322f /applications/driver_unit_tests/CMakeLists.txt
parentd66709083f08b4c32792d4a93e1e5b3c6b913fb2 (diff)
downloadethos-u-core-platform-b5f7cfe253dfeadd83caf60fde34b5b66f356782.tar.gz
Driver unit tests
Add driver unit tests that runs simple command streams directly on top of the NPU driver. Change-Id: I3fcce2a2bfbd458d14186b8fd13ba47174f49562
Diffstat (limited to 'applications/driver_unit_tests/CMakeLists.txt')
-rw-r--r--applications/driver_unit_tests/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/applications/driver_unit_tests/CMakeLists.txt b/applications/driver_unit_tests/CMakeLists.txt
new file mode 100644
index 0000000..b679358
--- /dev/null
+++ b/applications/driver_unit_tests/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright (c) 2021 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(driver_unit INTERFACE)
+
+target_sources(driver_unit INTERFACE
+ command_stream.cpp)
+
+ethosu_add_executable_test(driver_unit_irq PRIVATE
+ SOURCES irq.cpp
+ LIBRARIES driver_unit)
+
+ethosu_add_executable_test(driver_unit_conv PRIVATE
+ SOURCES conv.cpp
+ LIBRARIES driver_unit)