aboutsummaryrefslogtreecommitdiff
path: root/applications/driver_unit_tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLior Dekel <Lior.dekel@arm.com>2021-10-04 19:15:24 +0300
committerLior Dekel <Lior.dekel@arm.com>2021-10-06 15:43:24 +0300
commit52fddd00d0eb547d41074046c9f587a3a0679298 (patch)
tree66fc835afef7d9c50e3bc38f8d93160e4139142c /applications/driver_unit_tests/CMakeLists.txt
parent3e128627b8f604f47c8cc55cbb9d43c204f8e50f (diff)
downloadethos-u-core-platform-52fddd00d0eb547d41074046c9f587a3a0679298.tar.gz
NPU configuration support update in relevant apps.
Bare metal app - added all the configurations for the different NPUs. FreeRTOS app and driver_unit_conv test - excluded all NPU configurations except ethos-u55-128. Change-Id: I6f69526613cd18c572af1186e5997816fad246b4
Diffstat (limited to 'applications/driver_unit_tests/CMakeLists.txt')
-rw-r--r--applications/driver_unit_tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/applications/driver_unit_tests/CMakeLists.txt b/applications/driver_unit_tests/CMakeLists.txt
index b679358..45c733b 100644
--- a/applications/driver_unit_tests/CMakeLists.txt
+++ b/applications/driver_unit_tests/CMakeLists.txt
@@ -25,6 +25,12 @@ ethosu_add_executable_test(driver_unit_irq PRIVATE
SOURCES irq.cpp
LIBRARIES driver_unit)
+# Exclude driver_unit_conv if NPU configuration is not H128
+if (NOT ETHOSU_TARGET_NPU_CONFIG STREQUAL "ethos-u55-128")
+ message("Skipping driver_unit_conv application")
+ return()
+endif()
+
ethosu_add_executable_test(driver_unit_conv PRIVATE
SOURCES conv.cpp
LIBRARIES driver_unit)