aboutsummaryrefslogtreecommitdiff
path: root/applications/baremetal/CMakeLists.txt
diff options
context:
space:
mode:
authorLior Dekel <Lior.dekel@arm.com>2021-10-04 19:15:24 +0300
committerLior Dekel <Lior.dekel@arm.com>2021-10-06 15:43:24 +0300
commit52fddd00d0eb547d41074046c9f587a3a0679298 (patch)
tree66fc835afef7d9c50e3bc38f8d93160e4139142c /applications/baremetal/CMakeLists.txt
parent3e128627b8f604f47c8cc55cbb9d43c204f8e50f (diff)
downloadethos-u-core-platform-52fddd00d0eb547d41074046c9f587a3a0679298.tar.gz
NPU configuration support update in relevant apps.
Bare metal app - added all the configurations for the different NPUs. FreeRTOS app and driver_unit_conv test - excluded all NPU configurations except ethos-u55-128. Change-Id: I6f69526613cd18c572af1186e5997816fad246b4
Diffstat (limited to 'applications/baremetal/CMakeLists.txt')
-rw-r--r--applications/baremetal/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/applications/baremetal/CMakeLists.txt b/applications/baremetal/CMakeLists.txt
index 4f986ca..c0ecf03 100644
--- a/applications/baremetal/CMakeLists.txt
+++ b/applications/baremetal/CMakeLists.txt
@@ -25,17 +25,12 @@ if (IS_DIRECTORY ${BAREMETAL_PATH})
target_include_directories(baremetal_custom PRIVATE ${BAREMETAL_PATH})
endif()
-ethosu_add_executable_test(baremetal_keyword_cnn PRIVATE
- SOURCES main.cpp
- LIBRARIES ethosu_monitor)
-target_include_directories(baremetal_keyword_cnn PRIVATE models/keyword_spotting_cnn_small_int8)
-
-ethosu_add_executable_test(baremetal_keyword_dnn PRIVATE
- SOURCES main.cpp
- LIBRARIES ethosu_monitor)
-target_include_directories(baremetal_keyword_dnn PRIVATE models/keyword_spotting_dnn_medium_int8)
+file(GLOB models LIST_DIRECTORIES true "${CMAKE_CURRENT_SOURCE_DIR}/models/${ETHOSU_TARGET_NPU_CONFIG}/*")
-ethosu_add_executable_test(baremetal_keyword_ds_dnn PRIVATE
+foreach(model ${models})
+ get_filename_component(name ${model} NAME)
+ ethosu_add_executable_test(baremetal_${name} PRIVATE
SOURCES main.cpp
LIBRARIES ethosu_monitor)
-target_include_directories(baremetal_keyword_ds_dnn PRIVATE models/keyword_spotting_ds_dnn_large_clustered_int8)
+ target_include_directories(baremetal_${name} PRIVATE ${model})
+endforeach() \ No newline at end of file