aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 9d3b026687..edea34dfee 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -264,12 +264,15 @@ if (BUILD_ARMNN_SERIALIZER OR BUILD_CAFFE_PARSER OR BUILD_TF_PARSER OR BUILD_TF_
target_link_libraries(ExecuteNetwork armnnTfLiteParser)
endif()
if (BUILD_ONNX_PARSER)
- target_link_libraries(ExecuteNetwork armnnOnnxParser)
+ target_link_libraries(ExecuteNetwork armnnOnnxParser)
+ endif()
+ if (BUILD_ARMNN_TFLITE_DELEGATE)
+ target_link_libraries(ExecuteNetwork ArmnnDelegate::ArmnnDelegate)
endif()
-
target_link_libraries(ExecuteNetwork armnn)
- target_link_libraries(ExecuteNetwork ${CMAKE_THREAD_LIBS_INIT})
- addDllCopyCommands(ExecuteNetwork)
+
+ target_link_libraries(ExecuteNetwork ${CMAKE_THREAD_LIBS_INIT})
+ addDllCopyCommands(ExecuteNetwork)
endif()
if(BUILD_ACCURACY_TOOL)