aboutsummaryrefslogtreecommitdiff
path: root/src/timelineDecoder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/timelineDecoder/CMakeLists.txt')
-rw-r--r--src/timelineDecoder/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/timelineDecoder/CMakeLists.txt b/src/timelineDecoder/CMakeLists.txt
new file mode 100644
index 0000000000..6b8517acbc
--- /dev/null
+++ b/src/timelineDecoder/CMakeLists.txt
@@ -0,0 +1,21 @@
+#
+# Copyright © 2020 Arm Ltd. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+set(timelineDecoder_sources)
+list(APPEND timelineDecoder_sources
+ ../../include/armnn/profiling/ITimelineDecoder.hpp
+ TimelineCaptureCommandHandler.cpp
+ TimelineCaptureCommandHandler.hpp
+ TimelineDecoder.cpp
+ TimelineDecoder.hpp
+ TimelineDirectoryCaptureCommandHandler.cpp
+ TimelineDirectoryCaptureCommandHandler.hpp
+ )
+
+include_directories(../timelineDecoder ../profiling)
+
+add_library_ex(timelineDecoder SHARED ${timelineDecoder_sources})
+
+set_target_properties(timelineDecoder PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} ) \ No newline at end of file