aboutsummaryrefslogtreecommitdiff
path: root/src/armnnTestUtils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/armnnTestUtils/CMakeLists.txt')
-rwxr-xr-xsrc/armnnTestUtils/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/armnnTestUtils/CMakeLists.txt b/src/armnnTestUtils/CMakeLists.txt
index b90a71e66e..3f6fb415a2 100755
--- a/src/armnnTestUtils/CMakeLists.txt
+++ b/src/armnnTestUtils/CMakeLists.txt
@@ -29,11 +29,21 @@ list(APPEND armnnTestUtils_sources
TensorCopyUtils.cpp
TestUtils.cpp
TestUtils.hpp
+ )
+
+if(NOT BUILD_BARE_METAL)
+list(APPEND armnnTestUtils_sources
UnitTests.cpp
UnitTests.hpp
)
+endif()
+
-add_library_ex(armnnTestUtils SHARED ${armnnTestUtils_sources})
+if(BUILD_BARE_METAL)
+ add_library_ex(armnnTestUtils STATIC ${armnnTestUtils_sources})
+else()
+ add_library_ex(armnnTestUtils SHARED ${armnnTestUtils_sources})
+endif()
set_target_properties(armnnTestUtils PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
@@ -59,4 +69,4 @@ install(TARGETS armnnTestUtils
add_library(Armnn::armnnTestUtils ALIAS armnnTestUtils)
-set_target_properties(armnnTestUtils PROPERTIES VERSION ${ARMNN_TEST_UTILS_LIB_VERSION} SOVERSION ${ARMNN_TEST_UTILS_LIB_SOVERSION}) \ No newline at end of file
+set_target_properties(armnnTestUtils PROPERTIES VERSION ${ARMNN_TEST_UTILS_LIB_VERSION} SOVERSION ${ARMNN_TEST_UTILS_LIB_SOVERSION})