aboutsummaryrefslogtreecommitdiff
path: root/samples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'samples/CMakeLists.txt')
-rw-r--r--samples/CMakeLists.txt42
1 files changed, 24 insertions, 18 deletions
diff --git a/samples/CMakeLists.txt b/samples/CMakeLists.txt
index 210dc9c864..42e5a476cf 100644
--- a/samples/CMakeLists.txt
+++ b/samples/CMakeLists.txt
@@ -1,23 +1,29 @@
-if(BUILD_SAMPLE_APP AND ARMNNREF)
- add_executable(SimpleSample SimpleSample.cpp)
- target_link_libraries(SimpleSample armnn ${CMAKE_THREAD_LIBS_INIT})
+if (NOT BUILD_BARE_METAL)
+ if(BUILD_SAMPLE_APP AND ARMNNREF)
+ add_executable(SimpleSample SimpleSample.cpp)
+ target_link_libraries(SimpleSample armnn ${CMAKE_THREAD_LIBS_INIT})
- add_executable(AsyncExecutionSample AsyncExecutionSample.cpp)
- target_link_libraries(AsyncExecutionSample armnn ${CMAKE_THREAD_LIBS_INIT})
-endif()
+ add_executable(AsyncExecutionSample AsyncExecutionSample.cpp)
+ target_link_libraries(AsyncExecutionSample armnn ${CMAKE_THREAD_LIBS_INIT})
+ endif()
-if(BUILD_SAMPLE_APP AND SAMPLE_DYNAMIC_BACKEND)
- add_executable(DynamicSample DynamicSample.cpp)
- target_link_libraries(DynamicSample armnn ${CMAKE_THREAD_LIBS_INIT})
-endif()
+ if(BUILD_SAMPLE_APP AND SAMPLE_DYNAMIC_BACKEND)
+ add_executable(DynamicSample DynamicSample.cpp)
+ target_link_libraries(DynamicSample armnn ${CMAKE_THREAD_LIBS_INIT})
+ endif()
-if(BUILD_SAMPLE_APP AND ARMCOMPUTECL)
- add_executable(CustomMemoryAllocatorSample CustomMemoryAllocatorSample.cpp)
- target_link_libraries(CustomMemoryAllocatorSample armnn ${CMAKE_THREAD_LIBS_INIT})
-endif()
+ if(BUILD_SAMPLE_APP AND ARMCOMPUTECL)
+ add_executable(CustomMemoryAllocatorSample CustomMemoryAllocatorSample.cpp)
+ target_link_libraries(CustomMemoryAllocatorSample armnn ${CMAKE_THREAD_LIBS_INIT})
+ endif()
-if(BUILD_SAMPLE_APP AND ARMNNREF)
- add_executable(PreImportMemorySample PreImportMemorySample.cpp)
- target_link_libraries(PreImportMemorySample armnn ${CMAKE_THREAD_LIBS_INIT})
+ if(BUILD_SAMPLE_APP AND ARMNNREF)
+ add_executable(PreImportMemorySample PreImportMemorySample.cpp)
+ target_link_libraries(PreImportMemorySample armnn ${CMAKE_THREAD_LIBS_INIT})
+ endif()
+else()
+ if (ARMNNREF)
+ add_executable(BareMetalDeserializedGraph BareMetalDeserializedGraph.cpp)
+ target_link_libraries(BareMetalDeserializedGraph fmt pipeCommon pipeClient armnn)
+ endif()
endif()
-