aboutsummaryrefslogtreecommitdiff
path: root/profiling/server/src/basePipeServer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'profiling/server/src/basePipeServer/CMakeLists.txt')
-rw-r--r--profiling/server/src/basePipeServer/CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/profiling/server/src/basePipeServer/CMakeLists.txt b/profiling/server/src/basePipeServer/CMakeLists.txt
index e535cf2e66..b2cb82d816 100644
--- a/profiling/server/src/basePipeServer/CMakeLists.txt
+++ b/profiling/server/src/basePipeServer/CMakeLists.txt
@@ -6,15 +6,20 @@
if(BUILD_BASE_PIPE_SERVER)
set(BasePipeServer_sources)
list(APPEND BasePipeServer_sources
- BasePipeServer.cpp
- BasePipeServer.hpp
- ConnectionHandler.cpp
- ConnectionHandler.hpp
- )
+ BasePipeServer.cpp
+ BasePipeServer.hpp
+ ConnectionHandler.cpp
+ ConnectionHandler.hpp)
- include_directories(src/armnnUtils src/profiling)
+ include_directories(${PROJECT_SOURCE_DIR}/profiling/common/include)
+
+ if (BUILD_UNIT_TESTS)
+ target_include_directories(UnitTests PRIVATE ${PROJECT_SOURCE_DIR}/profiling/server/src/basePipeServer)
+ target_include_directories(UnitTests PUBLIC ${PROJECT_SOURCE_DIR}/profiling/common/include)
+ endif()
add_library_ex(armnnBasePipeServer SHARED ${BasePipeServer_sources})
+
set_target_properties(armnnBasePipeServer PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
set_target_properties(armnnBasePipeServer PROPERTIES VERSION ${GENERIC_LIB_VERSION}
SOVERSION ${GENERIC_LIB_SOVERSION})