aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe3240d0a9..f088a21bd5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -936,6 +936,8 @@ if(BUILD_GATORD_MOCK)
tests/profiling/gatordmock/PeriodicCounterCaptureCommandHandler.hpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.cpp
tests/profiling/gatordmock/PeriodicCounterSelectionResponseHandler.hpp
+ tests/profiling/gatordmock/StreamMetadataCommandHandler.cpp
+ tests/profiling/gatordmock/StreamMetadataCommandHandler.hpp
tests/profiling/timelineDecoder/ITimelineDecoder.h
tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.cpp
tests/profiling/timelineDecoder/TimelineCaptureCommandHandler.hpp
@@ -946,6 +948,9 @@ if(BUILD_GATORD_MOCK)
)
include_directories(${Boost_INCLUDE_DIRS} src/profiling)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling/gatordmock)
+ include_directories(${Boost_INCLUDE_DIRS} tests/profiling/timelineDecoder)
add_library_ex(gatordMockService STATIC ${gatord_mock_sources})