aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc4207b258..51c4cf2c97 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright © 2022 Arm Ltd and Contributors. All rights reserved.
+# Copyright © 2018-2022 Arm Ltd and Contributors. All rights reserved.
# Copyright 2020 NXP
# SPDX-License-Identifier: MIT
#
@@ -109,7 +109,6 @@ list(APPEND armnnUtils_sources
src/armnnUtils/Transpose.cpp
)
-add_library(armnnUtilsObj OBJECT ${armnnUtils_sources})
add_library_ex(armnnUtils STATIC ${armnnUtils_sources})
target_include_directories(armnnUtils PRIVATE src/backends)
@@ -839,7 +838,7 @@ if(BUILD_UNIT_TESTS)
list(APPEND unittest_sources $<TARGET_OBJECTS:${lib}>)
endforeach()
- add_executable(UnitTests ${unittest_sources} $<TARGET_OBJECTS:armnnUtilsObj>)
+ add_executable(UnitTests ${unittest_sources})
target_include_directories(UnitTests PRIVATE src/armnn)
target_include_directories(UnitTests PRIVATE src/armnnUtils)
target_include_directories(UnitTests PRIVATE src/armnnTestUtils)
@@ -1004,14 +1003,6 @@ install(
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
-install(
- TARGETS armnnUtilsObj
- EXPORT armnn-targets
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
- OBJECTS DESTINATION ${CMAKE_INSTALL_LIBDIR}
-)
-
####################################################
## Set export alias
set_target_properties(armnn