aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 763c07e275..d534c0a6d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -469,10 +469,12 @@ list(APPEND armnn_sources
src/profiling/Holder.cpp
src/profiling/Holder.hpp
src/profiling/IBufferManager.hpp
+ src/profiling/IConsumer.hpp
src/profiling/ICounterDirectory.hpp
src/profiling/ICounterRegistry.hpp
src/profiling/ICounterValues.hpp
src/profiling/ISendCounterPacket.hpp
+ src/profiling/ISendThread.hpp
src/profiling/IPacketBuffer.hpp
src/profiling/IPeriodicCounterCapture.hpp
src/profiling/IProfilingConnection.hpp
@@ -507,6 +509,8 @@ list(APPEND armnn_sources
src/profiling/RequestCounterDirectoryCommandHandler.hpp
src/profiling/SendCounterPacket.cpp
src/profiling/SendCounterPacket.hpp
+ src/profiling/SendThread.cpp
+ src/profiling/SendThread.hpp
src/profiling/SendTimelinePacket.cpp
src/profiling/SendTimelinePacket.hpp
src/profiling/SocketProfilingConnection.cpp