aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6856da63f6..89f0e5af56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -564,7 +564,7 @@ if(ARMCOMPUTECL)
target_link_libraries(armnn ${OPENCL_LIBRARIES})
endif()
-if(PROFILING_BACKEND_STREAMLINE)
+if(PROFILING_BACKEND_STREAMLINE AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
target_link_libraries(armnn pthread)
endif()
@@ -951,14 +951,14 @@ if(BUILD_GATORD_MOCK)
add_executable_ex(GartordMock tests/profiling/gatordmock/GatordMockMain.cpp)
- if(Threads_FOUND AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
- target_link_libraries(GartordMock pthread)
- endif()
-
target_link_libraries(GartordMock
armnn
gatordMockService
${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_SYSTEM_LIBRARY})
+ if(Threads_FOUND AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
+ target_link_libraries(GartordMock pthread)
+ endif()
+
endif()