aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2020-06-29 11:50:01 +0100
committerColm Donelan <colm.donelan@arm.com>2020-06-30 11:29:07 +0000
commit532a29d12d72f54549d8b71edd485c17af65698a (patch)
tree6748cc16706f52f413f7b2163a41d4807387cdf8 /tests/CMakeLists.txt
parent3b90af6bb79639d3813f21f3c3017503ee0c66af (diff)
downloadarmnn-532a29d12d72f54549d8b71edd485c17af65698a.tar.gz
IVGCVSW-4487 Remove boost::filesystem
* Replace filesystem::path * Replace filesystem::exists * Replace filesystem::is_directory * Replace filesystem::directory_iterator * Replace filesystem::filesystem_error exception * Replace filesystem::temp_directory_path * Replace filesystem::unique path * Replace filesystem::ofstream with std::ofstream * Replace filesystem::remove * Replace filesystem::is_regular_file * Replace boost::optional with armnn::Optional in touched files * Remove some superfluous includes * Update build guides, GlobalConfig.cmake and CMakeLists.txt * Remove redundant armnnUtils::Filesystem::Remove function. * Remove redundant armnnUtils::Filesystem::GetFileSize function. Temporarily adding back Boost::filesystem to enable Boost::dll. Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: Ifa46d4a0097d2612ddacd8e9736c0b36e365fb11
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 145af1225d..8d3d8320c2 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -29,7 +29,6 @@ if(BUILD_CAFFE_PARSER)
target_link_libraries(${testName} ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(${testName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${testName})
endmacro()
@@ -96,7 +95,6 @@ if(BUILD_TF_PARSER)
target_link_libraries(${testName} ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(${testName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${testName})
endmacro()
@@ -144,7 +142,6 @@ if (BUILD_TF_LITE_PARSER)
target_link_libraries(${testName} ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(${testName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${testName})
endmacro()
@@ -232,7 +229,6 @@ if (BUILD_ONNX_PARSER)
target_link_libraries(${testName} ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(${testName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${testName})
endmacro()
@@ -280,7 +276,6 @@ if (BUILD_ARMNN_SERIALIZER OR BUILD_CAFFE_PARSER OR BUILD_TF_PARSER OR BUILD_TF_
target_link_libraries(ExecuteNetwork ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(ExecuteNetwork
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(ExecuteNetwork)
endif()
@@ -305,7 +300,6 @@ if(BUILD_ACCURACY_TOOL)
endif()
target_link_libraries(${executorName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${executorName})
endmacro()
@@ -328,7 +322,6 @@ if(BUILD_ARMNN_QUANTIZER)
target_link_libraries(${executorName} ${CMAKE_THREAD_LIBS_INIT})
target_link_libraries(${executorName}
${Boost_SYSTEM_LIBRARY}
- ${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY})
addDllCopyCommands(${executorName})
endmacro()
@@ -349,5 +342,6 @@ if(BUILD_ARMNN_QUANTIZER)
ImageCSVFileGenerator/ImageCSVFileGenerator.cpp)
add_executable_ex(ImageCSVFileGenerator ${ImageCSVFileGenerator_sources})
+ target_include_directories(ImageCSVFileGenerator PRIVATE ../src/armnnUtils)
ImageTensorExecutor(ImageCSVFileGenerator)
endif()