aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2020-10-15 18:34:43 +0100
committerJan Eilers <jan.eilers@arm.com>2020-10-20 13:48:50 +0100
commit45274909b06a4882ada92899c58ee66194446135 (patch)
tree61a67ce012ef80fbd5d5f23cc8a22ba39ea2c7f2 /tests/CMakeLists.txt
parent3c24f43ff9afb50898d6a73ccddbc0936f72fdad (diff)
downloadarmnn-45274909b06a4882ada92899c58ee66194446135.tar.gz
IVGCVSW-5284 Refactor ExecuteNetwork
* Removed boost program options and replaced it with cxxopts * Unified adding, parsing and validation of program options into the struct ProgramOptions * Program options are now parsed directly into ExecuteNetworkParams which can be passed directly to MainImpl * Split NetworkExecutionUtils into header and source * Removed RunTest * Removed RunCsvTest * Removed RunClTuning * Moved MainImpl back to ExecuteNetwork.cpp * Added additional util functions The functionality of ExecuteNetwork remains the same. Only cl tuning runs need to be started separately and there is no short option for fp16-turbo-mode because -h is reserved in cxxopts to print help messages Signed-off-by: Jan Eilers <jan.eilers@arm.com> Change-Id: Ib9689375c81e1a184c17bb3ea66c3550430bbe09
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index b3496b42ee..7141edf47d 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -255,12 +255,19 @@ endif()
if (BUILD_ARMNN_SERIALIZER OR BUILD_CAFFE_PARSER OR BUILD_TF_PARSER OR BUILD_TF_LITE_PARSER OR BUILD_ONNX_PARSER)
set(ExecuteNetwork_sources
- ExecuteNetwork/ExecuteNetwork.cpp)
+ ExecuteNetwork/ExecuteNetwork.cpp
+ ExecuteNetwork/ExecuteNetworkProgramOptions.cpp
+ ExecuteNetwork/ExecuteNetworkProgramOptions.hpp
+ ExecuteNetwork/ExecuteNetworkParams.cpp
+ ExecuteNetwork/ExecuteNetworkParams.hpp
+ NetworkExecutionUtils/NetworkExecutionUtils.cpp
+ NetworkExecutionUtils/NetworkExecutionUtils.hpp)
add_executable_ex(ExecuteNetwork ${ExecuteNetwork_sources})
target_include_directories(ExecuteNetwork PRIVATE ../src/armnn)
target_include_directories(ExecuteNetwork PRIVATE ../src/armnnUtils)
target_include_directories(ExecuteNetwork PRIVATE ../src/backends)
+ target_include_directories(ExecuteNetwork PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
if (BUILD_ARMNN_SERIALIZER)
target_link_libraries(ExecuteNetwork armnnSerializer)