aboutsummaryrefslogtreecommitdiff
path: root/src/backends/tosaCommon/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2023-01-23 10:20:04 +0000
committerMatthew Sloyan <matthew.sloyan@arm.com>2023-01-23 14:51:11 +0000
commitc01da459e63461dc0ecfe855fd3254c938689386 (patch)
treede12240bac086b5ec751c3f76a2f64340b2e082a /src/backends/tosaCommon/CMakeLists.txt
parent6b74da0d8bca1d51c520bea275df1cc5560c0c96 (diff)
downloadarmnn-c01da459e63461dc0ecfe855fd3254c938689386.tar.gz
Refactor TOSA Common to be built without enabling the TOSA Reference backend
* The only way to build TOSA common was to enable ARMNNTOSAREF. * Only include and link the required headers/libraries for TOSA Common. * Remove duplicate include_directories calls. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ia5a19bf5b0bb903be0248ac550439df1e8ac5aa7
Diffstat (limited to 'src/backends/tosaCommon/CMakeLists.txt')
-rw-r--r--src/backends/tosaCommon/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/backends/tosaCommon/CMakeLists.txt b/src/backends/tosaCommon/CMakeLists.txt
index 1b1cc55eab..4a9cd574a9 100644
--- a/src/backends/tosaCommon/CMakeLists.txt
+++ b/src/backends/tosaCommon/CMakeLists.txt
@@ -1,12 +1,8 @@
#
-# Copyright © 2022 Arm Ltd and Contributors. All rights reserved.
+# Copyright © 2022-2023 Arm Ltd and Contributors. All rights reserved.
# SPDX-License-Identifier: MIT
#
-include_directories(SYSTEM ${FLATBUFFERS_INCLUDE_PATH})
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/third-party/half)
-include_directories(SYSTEM ${TOSA_SERIALIZATION_LIB_INCLUDE})
-
list(APPEND armnnTosaBackend_sources
TosaMappings.hpp
TosaMappings.cpp