aboutsummaryrefslogtreecommitdiff
path: root/src/backends/cl/CMakeLists.txt
diff options
context:
space:
mode:
authorAron Virginas-Tar <Aron.Virginas-Tar@arm.com>2018-10-25 11:10:49 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2018-10-25 14:06:56 +0100
commit9c5db11cfebfff87d18252ab2edb3b0bef9207b8 (patch)
treead2861fac26d355c5f1308e6f2cfe7a798ede893 /src/backends/cl/CMakeLists.txt
parent71007e4e16999ca96ab80941ca021b86342668d6 (diff)
downloadarmnn-9c5db11cfebfff87d18252ab2edb3b0bef9207b8.tar.gz
IVGCVSW-2058: Remove ARMCOMPUTE(CL/NEON)_ENABLED and ARMCOMPUTENEON_ENABLED from src/armnnUtils/ParserPrototxtFixture.hpp
Change-Id: Ief836fb80c4c966f1b76c9429d4a7fb644ceb73d
Diffstat (limited to 'src/backends/cl/CMakeLists.txt')
-rw-r--r--src/backends/cl/CMakeLists.txt32
1 files changed, 20 insertions, 12 deletions
diff --git a/src/backends/cl/CMakeLists.txt b/src/backends/cl/CMakeLists.txt
index 1f99017cdd..7182332956 100644
--- a/src/backends/cl/CMakeLists.txt
+++ b/src/backends/cl/CMakeLists.txt
@@ -3,21 +3,18 @@
# SPDX-License-Identifier: MIT
#
-list(APPEND armnnClBackend_sources
- ClBackend.cpp
- ClBackend.hpp
- ClBackendId.hpp
- ClContextControl.cpp
- ClContextControl.hpp
- ClLayerSupport.cpp
- ClLayerSupport.hpp
- ClWorkloadFactory.cpp
- ClWorkloadFactory.hpp
-)
-
if(ARMCOMPUTECL)
list(APPEND armnnClBackend_sources
+ ClBackend.cpp
+ ClBackend.hpp
ClBackendId.hpp
+ ClContextControl.cpp
+ ClContextControl.hpp
+ ClLayerSupport.cpp
+ ClLayerSupport.hpp
+ ClTensorHandle.hpp
+ ClWorkloadFactory.cpp
+ ClWorkloadFactory.hpp
OpenClTimer.cpp
OpenClTimer.hpp
)
@@ -27,6 +24,17 @@ if(ARMCOMPUTECL)
if(BUILD_UNIT_TESTS)
add_subdirectory(test)
endif()
+
+else()
+ list(APPEND armnnClBackend_sources
+ ClBackendId.hpp
+ ClContextControl.cpp
+ ClContextControl.hpp
+ ClLayerSupport.cpp
+ ClLayerSupport.hpp
+ ClWorkloadFactory.cpp
+ ClWorkloadFactory.hpp
+ )
endif()
add_library(armnnClBackend OBJECT ${armnnClBackend_sources})