aboutsummaryrefslogtreecommitdiff
path: root/src/armnnTfLiteParser/CMakeLists.txt
diff options
context:
space:
mode:
authorRob Hughes <robert.hughes@arm.com>2019-08-23 10:11:58 +0100
committerRob Hughes <robert.hughes@arm.com>2019-08-23 09:16:16 +0000
commit91e1d89ad35ad081a4d5995d541791fbefdb3060 (patch)
tree57022df335b5ccd38aa697394f97d12e6bfd3db5 /src/armnnTfLiteParser/CMakeLists.txt
parent1cd451cdd818e7df83cf60935abc54345fbc40e6 (diff)
downloadarmnn-91e1d89ad35ad081a4d5995d541791fbefdb3060.tar.gz
Fix Windows build:
* CMake "install" commands require a RUNTIME argument for platforms with DLLs (e.g. Windows). * Replace use of non-standard variable length array with vector * Remove unnecessary #include of unistd.h * Add #ifdefs to dynamic backend code to disable for non-Unix platforms where you can't use dlopen etc. We could implement this properly for Windows later using LoadLibrary etc., but for now erroring is fine. * Add missing #include of <algorithm> Change-Id: Ic8ef5fd599b37bf8772510157b6e479819f6a1eb
Diffstat (limited to 'src/armnnTfLiteParser/CMakeLists.txt')
-rwxr-xr-xsrc/armnnTfLiteParser/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/armnnTfLiteParser/CMakeLists.txt b/src/armnnTfLiteParser/CMakeLists.txt
index 8ff0837e31..17d4cf68c2 100755
--- a/src/armnnTfLiteParser/CMakeLists.txt
+++ b/src/armnnTfLiteParser/CMakeLists.txt
@@ -22,5 +22,6 @@ if(BUILD_TF_LITE_PARSER)
target_link_libraries(armnnTfLiteParser armnn ${FLATBUFFERS_LIBRARY})
install(TARGETS armnnTfLiteParser
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()