aboutsummaryrefslogtreecommitdiff
path: root/profiling/server/src/basePipeServer/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2020-04-20 21:21:07 +0100
committerFinn Williams <Finn.Williams@arm.com>2020-04-27 20:50:53 +0100
commit2ed809cb4765306b7af9b6968e2ec609d143979b (patch)
treea26b4d4e841434802c01b11a202ec58acf3cd61f /profiling/server/src/basePipeServer/CMakeLists.txt
parent4e755a50e35a1f5ac1b011dc4baf89e6d97f116e (diff)
downloadarmnn-2ed809cb4765306b7af9b6968e2ec609d143979b.tar.gz
IVGCVSW-4594 Refactor the GatordMockService and GatordMockMain to extract a BasePipeServer
Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I03c1b46104dadc491dba6075865e486f78aa60fa
Diffstat (limited to 'profiling/server/src/basePipeServer/CMakeLists.txt')
-rw-r--r--profiling/server/src/basePipeServer/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/profiling/server/src/basePipeServer/CMakeLists.txt b/profiling/server/src/basePipeServer/CMakeLists.txt
new file mode 100644
index 0000000000..e535cf2e66
--- /dev/null
+++ b/profiling/server/src/basePipeServer/CMakeLists.txt
@@ -0,0 +1,25 @@
+#
+# Copyright © 2020 Arm Ltd. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+if(BUILD_BASE_PIPE_SERVER)
+ set(BasePipeServer_sources)
+ list(APPEND BasePipeServer_sources
+ BasePipeServer.cpp
+ BasePipeServer.hpp
+ ConnectionHandler.cpp
+ ConnectionHandler.hpp
+ )
+
+ include_directories(src/armnnUtils src/profiling)
+
+ add_library_ex(armnnBasePipeServer SHARED ${BasePipeServer_sources})
+ set_target_properties(armnnBasePipeServer PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+ set_target_properties(armnnBasePipeServer PROPERTIES VERSION ${GENERIC_LIB_VERSION}
+ SOVERSION ${GENERIC_LIB_SOVERSION})
+
+ install(TARGETS armnnBasePipeServer
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif() \ No newline at end of file