aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorSadik Armagan <sadik.armagan@arm.com>2020-10-23 17:14:43 +0100
committerJim Flynn <jim.flynn@arm.com>2020-10-27 13:51:58 +0000
commit62483bee640e7d8accf6ac77b24c6e9828841851 (patch)
treeba7025bc86819c3d787428dd16b5be73b90a4353 /delegate/CMakeLists.txt
parent3d1323ff87fa92ff9cfc74097148b97fa1784416 (diff)
downloadarmnn-62483bee640e7d8accf6ac77b24c6e9828841851.tar.gz
IVGCVSW-5366 'Add a do nothing SubGraph class'
IVGCVSW-5373 'Implement the ABS operator in the Delegate' * Added a Switch statement into the VisitNode() function * Separated the Visit functions into the categorized source files * Implemented VisitElementwiseUnary() function * Added tests for ABS and SQRT Signed-off-by: Sadik Armagan <sadik.armagan@arm.com> Change-Id: If9654d0a8d8ff7dcd6fb5cbe0dc312941772affb
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt39
1 files changed, 31 insertions, 8 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index be18052548..aba27dfdaa 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -15,7 +15,31 @@ list(APPEND armnnDelegate_sources
include/armnn_delegate.hpp
include/DelegateOptions.hpp
src/armnn_delegate.cpp
- src/DelegateOptions.cpp)
+ src/DelegateOptions.cpp
+ src/Activation.hpp
+ src/ArgMinMax.hpp
+ src/BatchSpace.hpp
+ src/Comparison.hpp
+ src/Convolution.hpp
+ src/Control.hpp
+ src/DelegateUtils.hpp
+ src/ElementwiseBinary.hpp
+ src/ElementwiseUnary.hpp
+ src/Fill.hpp
+ src/FullyConnected.hpp
+ src/Gather.hpp
+ src/Lstm.hpp
+ src/Normalization.hpp
+ src/Pad.hpp
+ src/Pooling.hpp
+ src/Quantization.hpp
+ src/Redefine.hpp
+ src/Resize.hpp
+ src/Round.hpp
+ src/Slice.hpp
+ src/Softmax.hpp
+ src/SpaceDepth.hpp
+ src/Transpose.hpp)
add_library(armnnDelegate SHARED ${armnnDelegate_sources})
@@ -52,10 +76,6 @@ target_include_directories(armnnDelegate
PRIVATE
${TfLite_INCLUDE_DIR})
-target_include_directories(armnnDelegate
- SYSTEM PRIVATE
- "${TfLite_Schema_INCLUDE_PATH}")
-
## Add Flatbuffers dependency
find_package(Flatbuffers REQUIRED MODULE)
@@ -68,7 +88,10 @@ target_include_directories(armnnDelegate
set(armnnDelegate_unittest_sources)
list(APPEND armnnDelegate_unittest_sources
- src/test/ArmnnDelegateTest.cpp)
+ src/test/AbsTest.cpp
+ src/test/ArmnnDelegateTest.cpp
+ src/test/ElementwiseUnaryTestHelper.hpp
+ src/test/SqrtTest.cpp)
add_executable(DelegateUnitTests ${armnnDelegate_unittest_sources})
target_include_directories(DelegateUnitTests PRIVATE src)
@@ -81,8 +104,8 @@ target_include_directories(DelegateUnitTests
${TfLite_INCLUDE_DIR})
target_include_directories(DelegateUnitTests
- SYSTEM PRIVATE
- "${TfLite_Schema_INCLUDE_PATH}")
+ PRIVATE
+ ${Flatbuffers_INCLUDE_DIR})
####################################################
## Export targets