aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan OShea <ryan.oshea3@arm.com>2023-04-11 10:54:07 +0100
committerNarumol Prangnawarat <narumol.prangnawarat@arm.com>2023-04-13 12:45:40 +0000
commita37ccb006ad0bc49c34ff0d1741fe04d9ca55d5b (patch)
tree215ac44fbbe6093b5fe0eb3ee21fa09a31972c10 /delegate/CMakeLists.txt
parentc5ee0d7460f1e0ec7e2b0639e3e8962934c4df09 (diff)
downloadarmnn-a37ccb006ad0bc49c34ff0d1741fe04d9ca55d5b.tar.gz
IVGCVSW-7564 Implement Cast operator for Opaque Delegate
* Adds VisitCast function to Redefine.hpp * Enables Cast Test for OpaqueUnitTests * Various Fixes to the opaque delegate to allow operator to run Signed-off-by: Ryan OShea <ryan.oshea3@arm.com> Change-Id: I43d42eea5c987d6aed8a0f909a6bf583fddcc94e
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index f071c0e8fe..f8b6ea52d1 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -259,7 +259,9 @@ if(BUILD_UNIT_TESTS)
opaque/src/test/ArmnnOpaqueDelegateTest.cpp
opaque/src/test/DelegateTestInterpreter.cpp
test/TestUtils.hpp
- test/TestUtils.cpp)
+ test/TestUtils.cpp
+ test/CastTest.cpp
+ test/CastTestHelper.hpp)
# Until all operators are supported, we have to add tests one by one above to opaqueDelegate_unittest_sources.
# After we add can add commonDelegate_unittest_sources to the add_executable below.