aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2021-09-23 12:16:53 +0100
committerKeithARM <keith.davis@arm.com>2021-09-23 15:21:28 +0000
commitfca233eed08f4ec3b793fe76abae540e391f8319 (patch)
tree92c91e0fa06c58d72514ae39fc452b89b9b4b559 /delegate/CMakeLists.txt
parentce083d2ea1964411ce5d8f2ff05f6e0004978703 (diff)
downloadarmnn-fca233eed08f4ec3b793fe76abae540e391f8319.tar.gz
IVGCVSW-6181 patch to allow building against tflite > v2.3
Change-Id: I292add699b2af32fab87b98929fe6fee79fdf356 Signed-off-by: Jim Flynn <jim.flynn@arm.com>
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index aed77bf47e..9e4fdd9de3 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -68,6 +68,7 @@ endif()
target_link_libraries(armnnDelegate PUBLIC Armnn::Armnn)
## Add TfLite v2.3.1 dependency
+find_package(TfLiteSrc REQUIRED MODULE)
find_package(TfLite REQUIRED MODULE)
target_link_libraries(armnnDelegate PUBLIC ${TfLite_LIB})
@@ -115,6 +116,11 @@ target_include_directories(thirdparty_headers INTERFACE $<BUILD_INTERFACE:${ARMN
target_compile_options(thirdparty_headers INTERFACE -Wno-old-style-cast)
+add_library(profiling_library_headers INTERFACE)
+target_include_directories(profiling_library_headers INTERFACE $<BUILD_INTERFACE:${ARMNN_SOURCE_DIR}/profiling>
+ $<INSTALL_INTERFACE:include/profiling_library_headers>)
+
+
set_target_properties(armnnDelegate PROPERTIES VERSION ${DELEGATE_LIB_VERSION} SOVERSION ${DELEGATE_LIB_SOVERSION})
option(BUILD_UNIT_TESTS "Build unit tests" ON)
@@ -232,6 +238,7 @@ if(BUILD_UNIT_TESTS)
target_link_libraries(DelegateUnitTests PRIVATE tflite_headers)
target_link_libraries(DelegateUnitTests PRIVATE flatbuffer_headers)
+ target_link_libraries(DelegateUnitTests PRIVATE profiling_library_headers)
endif()