aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Davis <keith.davis@arm.com>2021-09-20 18:17:33 +0100
committerKeithARM <keith.davis@arm.com>2021-09-22 10:59:50 +0000
commitd62eef94ee206c788085e0a28f22377768fbe6f7 (patch)
treec54ad019681b36a5701fb094d19153beabdbbae5 /delegate/CMakeLists.txt
parentc316c980bff21b489b31ad8bbe074fcdf4ccddbd (diff)
downloadarmnn-d62eef94ee206c788085e0a28f22377768fbe6f7.tar.gz
IVGCVSW-6232 Integrate static library libtensorflow-lite.a with ArmNN
Signed-off-by: Keith Davis <keith.davis@arm.com> Change-Id: Ieb5fa0c4bb6753f0af21cfd80f1bf9faba55f7d0
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index effb093f4d..aed77bf47e 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -72,6 +72,12 @@ find_package(TfLite REQUIRED MODULE)
target_link_libraries(armnnDelegate PUBLIC ${TfLite_LIB})
+# lpthread and ldl are not required for Android
+if(NOT "${CMAKE_SYSTEM_NAME}" STREQUAL Android)
+ target_link_libraries(armnnDelegate PUBLIC -lpthread)
+ target_link_libraries(armnnDelegate PUBLIC -ldl)
+endif()
+
# Various tflite header files are not warning clean
# We can't change compilation flags on header files directly, so we need to add them to an interface library first
add_library(tflite_headers INTERFACE)