aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2020-10-15 13:53:27 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2020-10-16 09:43:58 +0100
commitfbba364350fcea447aaa6d108787820dea3fe23a (patch)
tree3fb1fc8e586b30ac031b6f2030600da695bd12c3 /CMakeLists.txt
parentf88e3cc93c0d20641b8dbb1cd3e019568502ba1d (diff)
downloadarmnn-fbba364350fcea447aaa6d108787820dea3fe23a.tar.gz
IVGCVSW-5435 Add FloatingPointComparison to remove boost::math::fpc uses
* Added FloatingPointComparison.hpp and FloatingPointComparisonTest.cpp, which compares two floats and returns true if the values are within a specified or default tolerance of each other. * Also removed boost::math::fpc from test/TensorHelpers.hpp to validate. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I164c32eccd213c53bb1bc4f9cd4ee4838f1781c9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7c8cb52fe..cf12a57b16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,7 @@ set(armnnUtils_sources)
list(APPEND armnnUtils_sources
include/armnnUtils/DataLayoutIndexed.hpp
include/armnnUtils/Permute.hpp
+ include/armnnUtils/FloatingPointComparison.hpp
include/armnnUtils/FloatingPointConverter.hpp
include/armnnUtils/TensorUtils.hpp
include/armnnUtils/Transpose.hpp
@@ -690,9 +691,10 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/UnitTests.cpp
src/armnn/test/UnitTests.hpp
src/armnn/test/UtilsTests.cpp
- src/armnnUtils/test/QuantizeHelperTest.cpp
- src/armnnUtils/test/PrototxtConversionsTest.cpp
+ src/armnnUtils/test/FloatingPointComparisonTest.cpp
src/armnnUtils/test/ParserHelperTest.cpp
+ src/armnnUtils/test/PrototxtConversionsTest.cpp
+ src/armnnUtils/test/QuantizeHelperTest.cpp
src/armnnUtils/test/TensorUtilsTest.cpp
src/profiling/test/BufferTests.cpp
src/profiling/test/FileOnlyProfilingDecoratorTests.cpp