aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2020-06-09 16:56:25 +0100
committerColm Donelan <Colm.Donelan@arm.com>2020-06-09 16:56:46 +0100
commit6350d27286114dfdae5f65ae1823ba1150087efb (patch)
treeb2941db6a0d1cfff1bdb9005e1a7b1c1c3149844 /CMakeLists.txt
parentb22a75e2aaec1175bbacba54e1a33a83f9749ce2 (diff)
downloadarmnn-6350d27286114dfdae5f65ae1823ba1150087efb.tar.gz
IVGCVSW-4968 Fix exception handling in TfLiteParser.
* The function TfLiteParser::CreateNetworkFromModel was continuing to parse the input file even after a fatal exception was encountered. restructure catch exceptions outside the for loop. * Add simple unit tests to test some exception handling. Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: I202ca6819d40a47159b4ac8f2847958f945666c2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a855cbac2b..0dc859bea5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -808,6 +808,7 @@ if(BUILD_UNIT_TESTS)
src/armnnTfLiteParser/test/GetTensorIds.cpp
src/armnnTfLiteParser/test/GetSubgraphInputsOutputs.cpp
src/armnnTfLiteParser/test/GetInputsOutputs.cpp
+ src/armnnTfLiteParser/test/TfLiteParser.cpp
)
# Generate SchemaText.cpp file which contains the TfLite schema text as a