aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Ward <james.ward@arm.com>2020-09-25 11:43:21 +0100
committerJames Ward <james.ward@arm.com>2020-09-30 08:41:31 +0000
commit22a4e1539aca7d39d7abc932f0a4d0b27beedf80 (patch)
tree95152943571413af5a3b550ac391bb17f258feef /CMakeLists.txt
parentba3ef18cb6117c49fcdbf177dce5991d6d679cbc (diff)
downloadarmnn-22a4e1539aca7d39d7abc932f0a4d0b27beedf80.tar.gz
IVGCVSW-4519 Remove Boost Variant and apply_visitor variant
* add mapbox/variant third party package Signed-off-by: James Ward <james.ward@arm.com> Change-Id: I181302780edd9dace40f158a11327316a12ce69a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c935e6b52d..592a77d969 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -543,6 +543,12 @@ list(APPEND armnn_sources
third-party/cxxopts/cxxopts.hpp
third-party/ghc/filesystem.hpp
third-party/half/half.hpp
+ third-party/mapbox/optional.hpp
+ third-party/mapbox/recursive_wrapper.hpp
+ third-party/mapbox/variant.hpp
+ third-party/mapbox/variant_cast.hpp
+ third-party/mapbox/variant_io.hpp
+ third-party/mapbox/variant_visitor.hpp
)
# Files used for Streamline-based profiling backend