aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Monahan <david.monahan@arm.com>2021-07-19 17:06:30 +0100
committerDavid Monahan <david.monahan@arm.com>2021-07-22 10:27:06 +0000
commit801e2d55de7a02b98f3d77dc9775b10b2bd9f16b (patch)
treea82709e7db40cb2982b2c5bcb4fba7d812965c7c /CMakeLists.txt
parentb49ed18ac76cbab23201598f08972cfed19cce4c (diff)
downloadarmnn-801e2d55de7a02b98f3d77dc9775b10b2bd9f16b.tar.gz
IVGCVSW-6077 Add the Custom Memory Allocator interface definition
* Added ICustomAllocator.hpp to include/armnn/backends/ * Added the ability to specify an ICustomAllocator to the CreationOptions Signed-off-by: David Monahan <david.monahan@arm.com> Change-Id: I820e468b691aa032c9bd2c1e1257dc9d02f981d9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4e0a38b38..13d3937689 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,6 +163,7 @@ list(APPEND armnn_sources
include/armnn/DescriptorsFwd.hpp
include/armnn/Exceptions.hpp
include/armnn/backends/ILayerSupport.hpp
+ include/armnn/backends/ICustomAllocator.hpp
include/armnn/IAsyncExecutionCallback.hpp
include/armnn/ILayerVisitor.hpp
include/armnn/INetwork.hpp