aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2021-04-15 20:46:24 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2021-04-15 20:51:23 +0100
commited7fce413410d15c501ea52f9e6bfbbf71b3daf1 (patch)
treef72645fdb44fec0fee95e00bd6c6f51b404ed5c7 /CMakeLists.txt
parent86723e67a940ed9f288c3cb59c120b9a10a1d590 (diff)
downloadarmnn-ed7fce413410d15c501ea52f9e6bfbbf71b3daf1.tar.gz
IVGCVSW-5829 Segfault in tflite-parser, int8 models
* Updated ParseSplit TfLiteParser function to read correct axis data. * Improved validation in ParseSplit and ParseSplitV function. * Added TensorFlow BOOL support to TfLiteParser. * Added supported ElementWiseUnary operators to TfLiteParser E.g. ABS, LOGICAL_NOT and RSQRT. * Removed ParseExp and ParseNeg function implementation in favour of reusable ParseElementWiseUnary function. * Removed Exp.cpp and Neg.cpp files and moved tests to ElementWiseUnary.cpp. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ibce36e3ce4d95755dda88abc2ddde1e07e62c5e2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a1db7bf29..8878065478 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -820,7 +820,7 @@ if(BUILD_UNIT_TESTS)
src/armnnTfLiteParser/test/Dequantize.cpp
src/armnnTfLiteParser/test/DetectionPostProcess.cpp
src/armnnTfLiteParser/test/Div.cpp
- src/armnnTfLiteParser/test/Exp.cpp
+ src/armnnTfLiteParser/test/ElementWiseUnary.cpp
src/armnnTfLiteParser/test/FullyConnected.cpp
src/armnnTfLiteParser/test/Gather.cpp
src/armnnTfLiteParser/test/L2Normalization.cpp
@@ -831,7 +831,6 @@ if(BUILD_UNIT_TESTS)
src/armnnTfLiteParser/test/Mean.cpp
src/armnnTfLiteParser/test/Minimum.cpp
src/armnnTfLiteParser/test/Multiplication.cpp
- src/armnnTfLiteParser/test/Neg.cpp
src/armnnTfLiteParser/test/Pack.cpp
src/armnnTfLiteParser/test/Pad.cpp
src/armnnTfLiteParser/test/Reduce.cpp