aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2020-01-17 11:18:01 +0000
committermike.kelly <mike.kelly@arm.com>2020-01-20 20:27:16 +0000
commite9d4220f84c14c57503958a3766a62c9bb0b254e (patch)
treed2add371232ba7239f876f3eacfd789ce2a805bb /CMakeLists.txt
parentdcf041cfd67acff7ebd524008050b4e1a435c0e5 (diff)
downloadarmnn-e9d4220f84c14c57503958a3766a62c9bb0b254e.tar.gz
IVGCVSW-4239 Remove dynamic link to libOpenCL.so
* Instead rely on ACL's dlopen() to dynamically load the libraries Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Change-Id: I2b451c1c382f3baf51665da9add8f2415353849a Signed-off-by: Teresa Charlin <teresa.charlinreyes@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8616d6dd1e..4d54137937 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,9 +561,6 @@ target_link_libraries(armnn ${Boost_THREAD_LIBRARY}
if(ARMCOMPUTENEON OR ARMCOMPUTECL)
target_link_libraries(armnn ${ARMCOMPUTE_LIBRARIES})
endif()
-if(ARMCOMPUTECL)
- target_link_libraries(armnn ${OPENCL_LIBRARIES})
-endif()
if(PROFILING_BACKEND_STREAMLINE AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
target_link_libraries(armnn pthread)