aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRob Hughes <robert.hughes@arm.com>2020-01-07 17:05:24 +0000
committerRob Hughes <robert.hughes@arm.com>2020-01-21 16:01:58 +0000
commitbdee4267583a7daaf9ea5284d2ff6d4bbb782229 (patch)
treef61b4fd91777509fc8d55a23fd25af5e8f15ceb8 /CMakeLists.txt
parent25b7436b02514145a0289daff78f5b9f64cdd0db (diff)
downloadarmnn-bdee4267583a7daaf9ea5284d2ff6d4bbb782229.tar.gz
Add thin abstraction layer for processes and filesystem
This is used instead of some hardcoded Unix calls and means this code now works on Windows (This is a rework of a previous patch which used boost, now that I have been informed that we are trying to move towards removing boost). Change-Id: Ib0d11055279bbd7b710f086e9890369e3ecbfe9a Signed-off-by: Robert Hughes <robert.hughes@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e39c2b8871..14c2c0c90f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,10 @@ list(APPEND armnnUtils_sources
include/armnnUtils/Permute.hpp
include/armnnUtils/FloatingPointConverter.hpp
include/armnnUtils/TensorUtils.hpp
+ src/armnnUtils/Filesystem.hpp
+ src/armnnUtils/Filesystem.cpp
+ src/armnnUtils/Processes.hpp
+ src/armnnUtils/Processes.cpp
src/armnnUtils/GraphTopologicalSort.hpp
src/armnnUtils/Half.hpp
src/armnnUtils/Permute.cpp