aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-10-11 17:19:56 +0100
committerNarumol Prangnawarat <narumol.prangnawarat@arm.com>2019-10-14 16:06:26 +0100
commit994b5349180b41849ee616fa4f0d3b94a928f48f (patch)
tree9e204588e3d6e997b46bd83ec935a33e32941e9c /CMakeLists.txt
parent53e469915bc6552c0d79cb6461512c7c1168ee2d (diff)
downloadarmnn-994b5349180b41849ee616fa4f0d3b94a928f48f.tar.gz
IVGCVSW-3971 Implement the Per-Job Counter Selection command handler
* Added new PerJobCounterSelectionCommandHandler class * The new handler drops the incoming packet without altering the state of the profiling service * Added unit test Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com> Change-Id: I2b1bb803318a9e6c438391a0985893eb412e7787
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e69d29c5aa..8973126cb0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -462,6 +462,8 @@ list(APPEND armnn_sources
src/profiling/PeriodicCounterCapture.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.cpp
src/profiling/PeriodicCounterSelectionCommandHandler.hpp
+ src/profiling/PerJobCounterSelectionCommandHandler.cpp
+ src/profiling/PerJobCounterSelectionCommandHandler.hpp
src/profiling/ProfilingConnectionDumpToFileDecorator.cpp
src/profiling/ProfilingConnectionDumpToFileDecorator.hpp
src/profiling/ProfilingConnectionFactory.cpp
@@ -917,4 +919,4 @@ if(BUILD_GATORD_MOCK)
${Boost_PROGRAM_OPTIONS_LIBRARY} ${Boost_SYSTEM_LIBRARY}
)
-endif() \ No newline at end of file
+endif()