aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2021-06-09 17:07:33 +0100
committerFinn Williams <Finn.Williams@arm.com>2021-06-23 17:14:53 +0100
commitf364d5391b08e9071cd965f5765385ec9156b652 (patch)
tree1ea93ed574a3eb51f5a1f4bb08dc1ad18aa1c6a2 /CMakeLists.txt
parent7a00eaa6ecf121623823b1951c0e6c9093271adf (diff)
downloadarmnn-f364d5391b08e9071cd965f5765385ec9156b652.tar.gz
IVGCVSW-6062 Rework the async threadpool
!android-nn-driver:5802 * Extract the threadpool from LoadedNetwork/Runtime * Refactor the threadpool to be handle multiple networks * Trim IAsyncExecutionCallback and add an InferenceId to AsyncExecutionCallback * Add AsyncCallbackManager class Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: I36aa2ad29c16bc10ee0706adfeb6b27f60012afb
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 426c089bd6..78c2f17e6d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,6 +180,7 @@ list(APPEND armnn_sources
include/armnn/QuantizedLstmParams.hpp
include/armnn/Tensor.hpp
include/armnn/TensorFwd.hpp
+ include/armnn/Threadpool.hpp
include/armnn/Types.hpp
include/armnn/TypesUtils.hpp
include/armnn/Utils.hpp
@@ -387,6 +388,7 @@ list(APPEND armnn_sources
src/armnn/SubgraphViewSelector.cpp
src/armnn/SubgraphViewSelector.hpp
src/armnn/Tensor.cpp
+ src/armnn/Threadpool.cpp
src/armnn/TypesUtils.cpp
src/armnn/Utils.cpp
src/armnn/WallClockTimer.cpp