aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2021-06-30 10:20:17 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2021-06-30 16:20:45 +0100
commit33f8987b5a437e8fc35cb38dac18007a8d92db6e (patch)
tree080d8b9e886ef577cea4725888a24907a3bc78a0 /CMakeLists.txt
parent0d677db72eb7945e304fc49cedf744f0c34ed330 (diff)
downloadarmnn-33f8987b5a437e8fc35cb38dac18007a8d92db6e.tar.gz
IVGCVSW-6161 ConstTensorsAsInput: Optimizer - Redirect ConstTensor layer members
* Optimization that searches for layers with ConstantLayers as inputs. * The layer member variables are then redirected to these ConstantLayers. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I24a2bf0e8575b808343e0bbe3897b344e94796ad
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ac7ecffaa..1ccc80df1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -593,6 +593,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/optimizations/OptimizeInversePermutesTests.cpp
src/armnn/test/optimizations/PermuteAndBatchToSpaceAsDepthToSpaceTests.cpp
src/armnn/test/optimizations/PermuteAsReshapeTests.cpp
+ src/armnn/test/optimizations/RedirectMembersToConstantInputsTests.cpp
src/armnn/test/optimizations/ReduceMultipleAxesTests.cpp
src/armnn/test/optimizations/SquashEqualSiblingsTests.cpp
src/armnn/test/optimizations/TransposeAsReshapeTests.cpp