aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Kelly <mike.kelly@arm.com>2021-06-27 22:39:21 +0100
committermike.kelly <mike.kelly@arm.com>2021-06-30 10:38:30 +0000
commit0d677db72eb7945e304fc49cedf744f0c34ed330 (patch)
treeee85b7f50e4ad9d5e568b46df46777513a2197cd /CMakeLists.txt
parent6f24b1aac9cbf5dfb3918cb59a7e903ddcec420e (diff)
downloadarmnn-0d677db72eb7945e304fc49cedf744f0c34ed330.tar.gz
IVGCVSW-6114 Create multiple LoadedNetworks from one OptimizedNetwork
* Added IOptimizedNetwork constructor that takes another IOptimizedNetwork and a ModelOptions. * Changed PreCompiledLayer to use shared_ptr rather than unique_ptr to store the PreCompiledObject (no interface changes). * Added unit tests to ensure that PreCompiledLayer::Clone() clones the pointer to the PreCompiledObject correctly. Signed-off-by: Mike Kelly <mike.kelly@arm.com> Change-Id: I3ef56055e0d189ffce9e651882d34da16c70a240
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78c2f17e6d..9ac7ecffaa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,6 +561,7 @@ set_target_properties(armnn PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION
if(BUILD_UNIT_TESTS)
set(unittest_sources)
list(APPEND unittest_sources
+ src/armnn/test/CloneTests.cpp
src/armnn/test/ConstTensorLayerVisitor.hpp
src/armnn/test/ConstTensorLayerVisitor.cpp
src/armnn/test/EndToEndTest.cpp