aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFinn Williams <Finn.Williams@arm.com>2021-06-29 15:50:08 +0100
committerfinn.williams <finn.williams@arm.com>2021-07-21 18:44:56 +0000
commitb49ed18ac76cbab23201598f08972cfed19cce4c (patch)
treeb100d19df7fdbfe009b2b8bf8048494bdab82a1a /CMakeLists.txt
parent9542f90d82a42096166d72109683abc165072297 (diff)
downloadarmnn-b49ed18ac76cbab23201598f08972cfed19cce4c.tar.gz
IVGCVSW-6176 Add support for shape_signature in the tflite parser
* tflite shape_signatures will now be the preferred way to detect dynamic tensors * add test utility to the parser that converts a model's tensors to dynamic * by default tests will run a dynamic version of the model in addition to the original * fix dynamic shape inference of unpack operator * reactivate and fix quantize test * add shape inference to expand dims Signed-off-by: Finn Williams <Finn.Williams@arm.com> Change-Id: If11ba19d813cd3590707583dff1e4eb0e6412a1d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0b03c0049..b4e0a38b38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -690,6 +690,7 @@ if(BUILD_UNIT_TESTS)
src/armnnTfLiteParser/test/Reshape.cpp
src/armnnTfLiteParser/test/ResizeBilinear.cpp
src/armnnTfLiteParser/test/ResizeNearestNeighbor.cpp
+ src/armnnTfLiteParser/test/Quantize.cpp
src/armnnTfLiteParser/test/Softmax.cpp
src/armnnTfLiteParser/test/SpaceToBatchND.cpp
src/armnnTfLiteParser/test/Shape.cpp