aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2021-03-31 17:40:00 +0100
committerFrancis Murtagh <francis.murtagh@arm.com>2021-04-14 08:17:12 +0000
commit7d22fa6d13feaf11d115735c18ada08dca513f4d (patch)
tree7768b2c99e36014811c286ba6188d58e191588ed /CMakeLists.txt
parentf18688ef344102c27f8ba2e8a5b7248c325b4f04 (diff)
downloadarmnn-7d22fa6d13feaf11d115735c18ada08dca513f4d.tar.gz
IVGCVSW-5795 Use ${CMAKE_THREAD_LIBS_INIT} throughout instead of 'pthread'
Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Change-Id: I32a92e0efabefd1e342203a13f11a622a3e25076
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6c3ef03a06..7a1db7bf29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -223,7 +223,7 @@ if(BUILD_ARMNN_QUANTIZER AND ARMNNREF)
${FLATBUFFERS_LIBRARY})
if(Threads_FOUND AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
- target_link_libraries(ArmnnQuantizerMain pthread)
+ target_link_libraries(ArmnnQuantizerMain ${CMAKE_THREAD_LIBS_INIT})
endif()
set_target_properties(armnnQuantizer PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION})
@@ -652,7 +652,7 @@ if(ARMCOMPUTENEON OR ARMCOMPUTECL)
endif()
if(PROFILING_BACKEND_STREAMLINE AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))
- target_link_libraries(armnn pthread)
+ target_link_libraries(armnn ${CMAKE_THREAD_LIBS_INIT})
endif()
set_target_properties(armnn PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION})