aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2021-05-03 12:22:03 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2021-05-20 13:57:36 +0000
commit5fc0fd6661f9647092deb052d052973a237bd52d (patch)
treef46c8ad169414ae400b22b046e25cedf7ba76c9d /CMakeLists.txt
parent1bed2f4f297d16f738b2c14f9e0fd24b7b03dade (diff)
downloadarmnn-5fc0fd6661f9647092deb052d052973a237bd52d.tar.gz
MLCE-418 Reduce layer does not support multiple axes
* Added backend specific optimization to chain new reduces layers for each axis to simulate behaviour of a layer with multiple axes. * Added function to calculate reduced output shape. * Added unit tests. * Includes rework to fix IVGCVSW-5987. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: I154b3698b5e6756b05b2a0b5a3f0896184efce72
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfdff89bbe..1e201ea0ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -566,6 +566,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/optimizations/OptimizeInversePermutesTests.cpp
src/armnn/test/optimizations/PermuteAndBatchToSpaceAsDepthToSpaceTests.cpp
src/armnn/test/optimizations/PermuteAsReshapeTests.cpp
+ src/armnn/test/optimizations/ReduceMultipleAxesTests.cpp
src/armnn/test/optimizations/SquashEqualSiblingsTests.cpp
src/armnn/test/optimizations/TransposeAsReshapeTests.cpp
src/armnn/test/OptionalTest.cpp