aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Bentham <matthew.bentham@arm.com>2019-04-30 10:17:40 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2019-04-30 12:42:19 +0100
commitd78b891d30b9b3a1aaf29e46c1d008bdc6bcd674 (patch)
tree1d0877c0f673af1305213454c186604b265fdd27 /CMakeLists.txt
parent386681af17ec143a0ea6f503e579e5cd8a334966 (diff)
downloadarmnn-d78b891d30b9b3a1aaf29e46c1d008bdc6bcd674.tar.gz
IVGCVSW-3021 Add end-to-end flow control integration test
Currently asserts that the net fails to optimise as that is the expected behaviour, but it's complete enough to exercise most of the code in SwitchLayer.cpp and MergeLayer.cpp Also, fix a bug in SwitchLayer::ValidateTensorShapesFromInputs found by the new test. Also, make topological sort slightly more robust to missing connections as it should not be the job of the sorter to validate the graph. Change-Id: I30b9e2d4769ab14a6820284871a79a5bb3eef1ef Signed-off-by: Matthew Bentham <matthew.bentham@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 297cbcd628..6dc1a1f02d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -421,6 +421,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/EndToEndTest.cpp
src/armnn/test/ExecutionFrameTest.cpp
src/armnn/test/FloatingPointConverterTest.cpp
+ src/armnn/test/FlowControl.cpp
src/armnn/test/GraphTests.cpp
src/armnn/test/GraphUtils.cpp
src/armnn/test/GraphUtils.hpp