aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatteo Martincigh <matteo.martincigh@arm.com>2019-06-20 17:17:45 +0100
committerMatthew Bentham <matthew.bentham@arm.com>2019-06-24 12:50:46 +0000
commitbf0e7226ef0ba5ee3e5c7144368c4c9c379b0330 (patch)
treeb0954a42b260395303d0dda7dd67f83c118a5d44 /CMakeLists.txt
parent6858d3fb714cc20d5fcfd814c35ed3a84dc82145 (diff)
downloadarmnn-bf0e7226ef0ba5ee3e5c7144368c4c9c379b0330.tar.gz
IVGCVSW-3267 Add more code coverage to the PReLU layer
* Added more unit tests to cover all code branches * Moved the InferOutput tests to separate files * Created convenience ARMNN_SIMPLE_TEST_CASE macro * Created TestUtils file for common utility functions Change-Id: Id971d3cf77005397d1f0b2783fab68b1f0bf9dfc Signed-off-by: Matteo Martincigh <matteo.martincigh@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 976f8dee2e..8fa2bf904d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -471,7 +471,8 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/GraphUtils.cpp
src/armnn/test/GraphUtils.hpp
src/armnn/test/InstrumentTests.cpp
- src/armnn/test/LayerValidateOutputTest.cpp
+ src/armnn/test/InferOutputTests.cpp
+ src/armnn/test/InferOutputTests.hpp
src/armnn/test/ModelAccuracyCheckerTest.cpp
src/armnn/test/NetworkTests.cpp
src/armnn/test/ObservableTest.cpp
@@ -493,6 +494,8 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/TestNameOnlyLayerVisitor.hpp
src/armnn/test/TestNameAndDescriptorLayerVisitor.hpp
src/armnn/test/TestNameAndDescriptorLayerVisitor.cpp
+ src/armnn/test/TestUtils.cpp
+ src/armnn/test/TestUtils.hpp
src/armnn/test/UnitTests.cpp
src/armnn/test/UnitTests.hpp
src/armnn/test/UtilsTests.cpp