aboutsummaryrefslogtreecommitdiff
path: root/reference_model/CMakeLists.txt
diff options
context:
space:
mode:
authorJerry Ge <jerry.ge@arm.com>2023-10-30 10:18:45 -0700
committerJerry Ge <jerry.ge@arm.com>2023-11-16 21:56:43 +0000
commit5637a8606bc3caeec3c590350de770c7fcec8dd7 (patch)
treeb83a0d33d8a76c77cf560026e6cc8e8db22ad712 /reference_model/CMakeLists.txt
parentd3797f014811ca1ea876989b4839a8297eb1731e (diff)
downloadreference_model-5637a8606bc3caeec3c590350de770c7fcec8dd7.tar.gz
Support loading shared libraries for custom operators
- Add a new command line option to allow users to specify a custom defined dll library - Add a custom registry to store all registered libraries - Add a dummy example (custom_op_example.cpp) for demonstrating this new feature Signed-off-by: Jerry Ge <jerry.ge@arm.com> Change-Id: I7c360835933f77e33fcbd772cabfe01d82282d47
Diffstat (limited to 'reference_model/CMakeLists.txt')
-rw-r--r--reference_model/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/reference_model/CMakeLists.txt b/reference_model/CMakeLists.txt
index d36167a..5c40ce5 100644
--- a/reference_model/CMakeLists.txt
+++ b/reference_model/CMakeLists.txt
@@ -131,6 +131,8 @@ target_link_libraries(tosa_reference_model_lib
set(PUBLIC_HEADERS)
list(APPEND PUBLIC_HEADERS
+ include/custom_op_interface.h
+ include/custom_registry.h
include/debug_modes.def
include/debug_types.h
include/dtype.h
@@ -202,6 +204,7 @@ if(BUILD_TOSA_REFERENCE_MODEL_EXECUTABLE)
${SERIALIZATION_LIB}
nlohmann_json::nlohmann_json
cxxopts
+ ${CMAKE_DL_LIBS}
)
install(TARGETS tosa_reference_model DESTINATION bin)