aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index f5f82bd0..ee4e40e8 100644
--- a/setup.py
+++ b/setup.py
@@ -26,12 +26,12 @@ from setuptools import setup
this_directory = path.abspath(path.dirname(__file__))
with open(path.join(this_directory, "README.md"), encoding="utf-8") as f:
long_description = f.read()
- # Replace local Markdown links with URLs
- tag = "2.0.0"
+ # Replace local file links with URLs
+ tag = "2.0.1"
url = f"https://review.mlplatform.org/plugins/gitiles/ml/ethos-u/ethos-u-vela/+/refs/tags/{tag}/"
- for markdown in set(re.findall(r"\(.+\.md\)", long_description)):
- link = f"({url}{markdown[1:-1]})"
- long_description = long_description.replace(markdown, link)
+ for link in set(re.findall(r"\[.+\]\((.+?)\)", long_description)):
+ if path.exists(path.join(this_directory, link)):
+ long_description = long_description.replace(link, url + link)
mlw_module = Extension(
"ethosu.mlw_codec",