aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaul Farkas <raul.farkas@arm.com>2023-03-14 15:19:46 +0000
committerRaul Farkas <raul.farkas@arm.com>2023-03-24 09:40:32 +0000
commitfcda685927ae4b29a79e10eca051b48acbf46f71 (patch)
treeb249672105a6df4b57e3834da8cec3c1ca73e8b0 /setup.py
parent6986a079020ab6344c9191aa67af13beeb475593 (diff)
downloadethos-u-vela-fcda685927ae4b29a79e10eca051b48acbf46f71.tar.gz
MLBEDSW-4178: Add automatic tag handling
* Add automatic tag handling when building source distribution. Change-Id: Ia20df463ae3eddf78de7e0b710c9c2279ddf61cd Signed-off-by: Raul Farkas <raul.farkas@arm.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5a7a7fc1..6b7186bf 100644
--- a/setup.py
+++ b/setup.py
@@ -22,6 +22,7 @@ import re
from setuptools import Extension
from setuptools import setup
from setuptools.command.build_ext import build_ext
+from setuptools_scm import get_version
class BuildExtension(build_ext):
@@ -41,7 +42,7 @@ class BuildExtension(build_ext):
this_directory = os.path.abspath(os.path.dirname(__file__))
with open(os.path.join(this_directory, "README.md"), encoding="utf-8") as f:
long_description = f.read()
- tag = "3.7.0"
+ tag = get_version()
url = f"https://review.mlplatform.org/plugins/gitiles/ml/ethos-u/ethos-u-vela/+/refs/tags/{tag}/"
# Find all markdown links that match the format: [text](link)
for match, link in re.findall(r"(\[.+?\]\((.+?)\))", long_description):