aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Hall <tim.hall@arm.com>2022-09-28 12:47:54 +0100
committerTim Hall <tim.hall@arm.com>2022-10-03 18:07:52 +0100
commitdda4caed56d2cd3a9d5927bf405859c1777ac909 (patch)
tree76233bb19ab6f034c7a0613968cc7937959624b4 /setup.py
parent61f05d92525447f62b9531b17297822b9232e8ab (diff)
downloadethos-u-vela-dda4caed56d2cd3a9d5927bf405859c1777ac909.tar.gz
MLBEDSW-6979: Installing on aarch64 with Python 3.8 fails
- The issue is due to the numpy version needed when installing on aarch64 with Python 3.8 and TensorFlow - The fix is to use the python_version variable when specifing the numpy version Signed-off-by: Tim Hall <tim.hall@arm.com> Change-Id: I6134b6dbccefc3be0b87feb17e3176b7f42641b3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b3011f86..3eb79b61 100644
--- a/setup.py
+++ b/setup.py
@@ -94,11 +94,12 @@ setup(
python_requires="~=3.7",
install_requires=[
"flatbuffers==2.0.7",
- "numpy<=1.21.3",
+ "numpy<=1.21.3; python_version<='3.7'",
+ "numpy; python_version>'3.7'",
"lxml>=4.5.1",
],
entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
ext_modules=[mlw_module],
cmdclass={"build_ext": BuildExtension}, # type: ignore[dict-item]
- setup_requires=["numpy<=1.21.3", "setuptools_scm"],
+ setup_requires=["numpy<=1.21.3; python_version<='3.7'", "numpy; python_version>'3.7'", "setuptools_scm<6.0"],
)