aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFredrik Svedberg <Fredrik.Svedberg@arm.com>2020-12-11 13:42:22 +0100
committerpatrik.gustavsson <patrik.gustavsson@arm.com>2020-12-18 12:16:19 +0000
commit5b513886ab120023eb1319d4883b175db8b7de3a (patch)
tree8ed296f6567daac9c1a564ad417f3d14ab1b7186 /setup.py
parent6c74c3bcaa733aa062c15d606726722b19c0dfdb (diff)
downloadethos-u-vela-5b513886ab120023eb1319d4883b175db8b7de3a.tar.gz
[MLBEDSW-297] Setup and run on Microsoft Windows
Various updates to make vela run and produce identical output on Microsoft Windows. * Fixed overflow errors * Fixed compile warnings * Avoid problematic numpy version * Updated README.md Signed-off-by: Fredrik Svedberg <Fredrik.Svedberg@arm.com> Change-Id: Ie48c63a92a00c81b3247d07f05b75d881319ddbb
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 805062b0..bb2e8a09 100644
--- a/setup.py
+++ b/setup.py
@@ -76,7 +76,12 @@ setup(
keywords=["ethos-u", "vela compiler", "tflite", "npu"],
packages=find_namespace_packages(include=["ethosu.*"]),
python_requires="~=3.6", # We support only 3.6+
- install_requires=["flatbuffers==1.11.0", "numpy>=1.16.6", "lxml>=4.5.1"],
+ install_requires=[
+ "flatbuffers==1.11.0",
+ "numpy>=1.16.6",
+ "numpy>=1.16.6,<1.19.4 ; platform_system=='Windows'",
+ "lxml>=4.5.1",
+ ],
entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
ext_modules=[mlw_module, tensor_allocator_module],
setup_requires=["setuptools_scm"],