aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRaul Farkas <raul.farkas@arm.com>2023-01-16 16:52:18 +0000
committerRaul Farkas <raul.farkas@arm.com>2023-02-09 15:38:02 +0000
commit428a8d54f574a73804274e53e61f711aebc25a0a (patch)
tree251bb0a54234fb9a62b8a22a9ba9f82e2b5f3ca5 /setup.py
parent59b9ab9121d17793b5a240f7c51028b6b37a7a6e (diff)
downloadethos-u-vela-428a8d54f574a73804274e53e61f711aebc25a0a.tar.gz
MLBEDSW-6982: Move to setup.cfg and pyproject.toml3.7.0.rc1
- Move all static information from setup.py to newly added pyproject.toml - Add setup.cfg used for static information that cannot be added to pyproject.toml due to it still being in beta. - Modify mlw_codec to to throw a real python exception when importing NumPy arrays instead of just printing them to stdout. - Surround mlw_codec import with try catch statement to catch NumPy C API mismatch errors and throw them again with a more detailed message. - Update README.md with documentation about known issue with changing used NumPy version after installing ethos-u-vela. Change-Id: I1eeee5536be7c1744e30d6088f7069fbb1403e06 Signed-off-by: Raul Farkas <raul.farkas@arm.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 1 insertions, 38 deletions
diff --git a/setup.py b/setup.py
index 69a115a9..29df63b0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-# SPDX-FileCopyrightText: Copyright 2020-2022 Arm Limited and/or its affiliates <open-source-office@arm.com>
+# SPDX-FileCopyrightText: Copyright 2020-2023 Arm Limited and/or its affiliates <open-source-office@arm.com>
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -61,46 +61,9 @@ mlw_module = Extension(
)
setup(
- name="ethos-u-vela",
use_scm_version=True,
- description="Neural network model compiler for Arm Ethos-U NPUs",
long_description=long_description,
long_description_content_type="text/markdown",
- url="https://git.mlplatform.org/ml/ethos-u/ethos-u-vela.git/",
- author="Arm Ltd.",
- author_email="mlg-vela@arm.com",
- license="Apache License 2.0",
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Apache Software License",
- "Operating System :: POSIX :: Linux",
- "Operating System :: Microsoft :: Windows :: Windows 10",
- "Programming Language :: C",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.7",
- "Topic :: Scientific/Engineering :: Artificial Intelligence",
- "Topic :: Software Development :: Compilers",
- ],
- keywords=["ethos-u", "vela compiler", "tflite", "npu"],
- packages=[
- "ethosu",
- "ethosu.vela",
- "ethosu.vela.ethos_u55_regs",
- "ethosu.vela.tflite",
- "ethosu.vela.tosa",
- "ethosu.mlw_codec",
- ],
- package_data={"ethosu": ["config_files/*/*.ini"]},
- python_requires="~=3.7",
- install_requires=[
- "flatbuffers==2.0.7",
- "numpy<=1.21.3; python_version<='3.7'",
- "numpy; python_version>'3.7'",
- "lxml>=4.5.1",
- ],
- entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
ext_modules=[mlw_module],
cmdclass={"build_ext": BuildExtension}, # type: ignore[dict-item]
- setup_requires=["numpy<=1.21.3; python_version<='3.7'", "numpy; python_version>'3.7'", "setuptools_scm<6.0"],
)