aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwight Lidman <dwight.lidman@arm.com>2021-05-12 19:14:27 +0200
committerpatrik.gustavsson <patrik.gustavsson@arm.com>2021-05-18 10:08:09 +0000
commit06329fc1c4c802ed203cb32cc6eda30871577bfb (patch)
tree8026495df43e47e1f6160497258de64254322ce7 /setup.py
parente917cdcc659a7195987dbdb83e86597953c9aacd (diff)
downloadethos-u-vela-06329fc1c4c802ed203cb32cc6eda30871577bfb.tar.gz
MLBEDSW-4576: Update setup.py
This commit changes setup.py to correctly state that we only officially support Python 3.6. Signed-off-by: Dwight Lidman <dwight.lidman@arm.com> Change-Id: Iaa678d1df6a154fdb24f3b3994015a3e842d7696
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index d43ef16c..b2c25ead 100644
--- a/setup.py
+++ b/setup.py
@@ -78,14 +78,13 @@ setup(
"Programming Language :: C",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.6 :: Only",
"Topic :: Scientific/Engineering :: Artificial Intelligence",
"Topic :: Software Development :: Compilers",
],
keywords=["ethos-u", "vela compiler", "tflite", "npu"],
packages=find_namespace_packages(include=["ethosu.*"]),
- python_requires="~=3.6", # We support only 3.6+
+ python_requires="~=3.6", # We only test for 3.6.*
install_requires=[
"flatbuffers==1.12.0",
"numpy>=1.16.6",