aboutsummaryrefslogtreecommitdiff
path: root/driver_library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'driver_library/CMakeLists.txt')
-rw-r--r--driver_library/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/driver_library/CMakeLists.txt b/driver_library/CMakeLists.txt
new file mode 100644
index 0000000..4d9001f
--- /dev/null
+++ b/driver_library/CMakeLists.txt
@@ -0,0 +1,36 @@
+#
+# Copyright (c) 2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.0.2)
+
+# set the project name and version
+project("driver_library" VERSION 1.0.0 LANGUAGES C CXX)
+
+# Build the driver library
+add_library(ethosu STATIC "src/ethosu.cpp")
+
+# Add public include directory and select which files to install
+target_include_directories(ethosu PUBLIC "include")
+set_target_properties(ethosu PROPERTIES PUBLIC_HEADER "include/ethosu.hpp")
+set_target_properties(ethosu PROPERTIES VERSION ${PROJECT_VERSION})
+
+# Install library and public headers
+install(TARGETS ethosu
+ LIBRARY DESTINATION "lib"
+ ARCHIVE DESTINATION "lib"
+ PUBLIC_HEADER DESTINATION "include") \ No newline at end of file