aboutsummaryrefslogtreecommitdiff
path: root/drivers/mhu_v2/CMakeLists.txt
diff options
context:
space:
mode:
authorJonny Svärd <jonny.svaerd@arm.com>2020-11-16 16:18:07 +0100
committerJonny Svärd <jonny.svaerd@arm.com>2020-11-26 11:36:05 +0100
commit9fc527b8b01847b16a8aa577dec4c6d9401a2ef0 (patch)
treef5f9cbd08ec674f9a3fcbc707044ba3f38bed379 /drivers/mhu_v2/CMakeLists.txt
parent34e249686923a0299a041fb6af10e56fc9fb76cd (diff)
downloadethos-u-core-software-9fc527b8b01847b16a8aa577dec4c6d9401a2ef0.tar.gz
Add basic MHU drivers
Add MHUv2 doorbell driver implementation Add MHU doorbell driver for Juno board Add a dummy MHU driver Add some comments to the mailbox header file Change-Id: I0950a7ca3afeec88ca691ca2486022dfbb3319b8
Diffstat (limited to 'drivers/mhu_v2/CMakeLists.txt')
-rw-r--r--drivers/mhu_v2/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/drivers/mhu_v2/CMakeLists.txt b/drivers/mhu_v2/CMakeLists.txt
new file mode 100644
index 0000000..2ecf35a
--- /dev/null
+++ b/drivers/mhu_v2/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2020 Arm Limited. All rights reserved.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the License); you may
+# not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an AS IS BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+add_library(ethosu_mhu_v2 STATIC)
+target_include_directories(ethosu_mhu_v2 PUBLIC include)
+
+target_sources(ethosu_mhu_v2 PRIVATE src/mhu_v2.cc)
+target_link_libraries(ethosu_mhu_v2 PRIVATE ethosu_mailbox)